Page 1 of 1

Editor Bug: Plaque Event Editor Delete Button Breaks Plaque

Posted: Mon Dec 18, 2017 1:42 pm
by rleduc
I believe I have discovered a bug with the editor. If you click on a plaque, and then "edit events" to get to the plaque event pop-up, using the red "delete" button to delete events attached to the plaque makes it impossible to add any further events to the plaque. I've been able to replicate this consistently using the following process:

1. Create a plaque
2. Click on the plaque and "Edit Events"
3. Add a an event and save.
4. Go back into the plaque and "Edit Events"
5. Click "Delete"
6. Go back into the plaque and "Edit Events"
7. Try adding and event and save - no longer works

When I try adding an event now, I get the blue "Saving" pop-up, but the Event editor does not close automatically and when you exit the event editor and return to it, none of the events that I tried to add are there. I've found that everything continues to work fine when the "Remove" link to the right of every row is used to remove events individually. Using the remove link, I can add and remove events as much as I want, but as soon as I use the red "Delete" button the plaque becomes unusable and I can no longer add events.

I am using Chrome with the editor.

Re: Editor Bug: Plaque Event Editor Delete Button Breaks Plaque

Posted: Wed Jan 03, 2018 12:11 pm
by chrish
I am able to replicate this. Nice find and sorry that it's there. My guess is that a workaround would be to create a new plaque. I know that sucks if you've got to move a lot of other stuff around.

For now and for others, try not to use that delete button!

Re: Editor Bug: Plaque Event Editor Delete Button Breaks Plaque

Posted: Wed Jan 03, 2018 12:28 pm
by djgagnon
Thanks for the great documentation here rleduc. We will get this resolved as soon as possible. In the meantime, I think Chris has the best possible stratigy.

David