Inability to edit posts in Siftr iOS app.
  • l-gun
    Posts: 17
    Joined: Tue Feb 28, 2017 3:30 pm

    Inability to edit posts in Siftr iOS app.

    by l-gun » Mon Apr 15, 2019 12:37 pm

    I use Siftr with 2nd and 3rd graders. They use the app on iPads.

    When we are "out in the field," there are lots of times when there isn't time to post a full caption. So, I'll have them start (or just enter "...") with the intention of finishing later.

    Trouble we run into is an inability to "edit post." We select "edit post," then add/adjust the text, but then get a "missing photo" error message, which prevents the edits from getting finalized.


    Going in through a web browser (Safari) does allow the edits, but the SEARCH feature doesn't seem to find the Siftr, so that workaround isn't smooth.

  • User avatar
    Posts: 277
    Joined: Mon Oct 10, 2016 5:45 pm
    Location: Albuquerque, NM

    Re: Inability to edit posts in Siftr iOS app.

    by chrish » Mon Apr 15, 2019 4:41 pm

    I have just tried to replicate this but editing posts on iOS works fine for me. Are there any other possible differences between what you do in the field and what happens back at the ranch? Things like different devices, log ins, network environments?
  • l-gun
    Posts: 17
    Joined: Tue Feb 28, 2017 3:30 pm

    Re: Inability to edit posts in Siftr iOS app.

    by l-gun » Tue Apr 16, 2019 9:28 am

    Thanks, Chris, for helping me troubleshoot.

    I just did a test myself, within my classroom. I made a post, then immediately tried to edit it. Same issue as originally described.

    Could do a screen capture video to illustrate, if somehow that were useful, but I'm guessing that understanding of the issue isn't the problem here. More of a matter of determining why it occurs with our devices.

    And, in thinking about it more, I am now recalling that we may not have the newest version of Siftr. I ran into a bunch of problems about a month ago, but ended up not updating because I didn't want to risk further problems right before an important field experience.

    I guess if I really want to explore fixing the (possible) bug I am talking about, I need to try the update first.

    I will copy and paste below some emails I exchanged with a friend involved with Field Day about the earlier trouble...just in case those issues are noteworthy.


    Larry G.

    On Tue, Mar 19, 2019 at 7:05 AM Larry Gundlach <> wrote:
    Hi _______________,

    Haven't used Siftr in a while (until a week ago), but planning to today and tomorrow. (Practice today and big field trip tomorrow.)

    I feel like it is behaving weirdly today, and I am starting to get worried about the trip tomorrow.

    Anyone I can email or call to see if they are currently experiencing problems, or should I post to the forum?



    On Tue, Mar 19, 2019 at 7:25 AM Larry Gundlach <> wrote:

    Lots of strange things happening, hard to know how to describe them all.

    App icon changing from black and yellow to blue and red on white seems to be a sign that version of the app is an issue?? We just re-installed last week, but perhaps there has been a recent update.

    I am trying some workarounds to some other problems I have not described. Current biggest issue is that some iPads I've tested get kind of "stuck" with "Syncing 1 post" message indefinitely...or at least for quite a long time.This persists even after logging out and then in and restarting iPads.

    I can check in after we do our "practice version" from 8-9 AM. Sorry, not trying to use you as tech support. Mainly want the quickest way to check in with someone in the know to know if I should abort tomorrow's trip plan.


    Mar 20, 2019, 9:08 PM

    Thanks for checking in, ___________!

    Did use Siftr, and it went pretty well overall.

    I was having so many issues during that 24+ hour period that it was really hard to tell what was going on. Many were on the editor side, but not exclusively.

    I asked our tech people to help update to the newest version of the app. I think I mistakenly said Aris, though, so Siftr stayed the same. By the time we figured that out, we had already done our practice run and it went pretty smoothly. So I just left well enough alone!

    I doubt anybody (in my class) has the most recent version, except possibly me. My app icon is blue on white. The kids have yellow on black. Mine was crashing a lot more than theirs.

    I'll forward a message that shows what we are up to. No need to look at it, though. We just need to get to spring break!